1. Hello guest! Are you a Tegu enthusiast? If so, we invite you to join our community! Our site is specifically designed for you and it's a great place for Tegu enthusiasts to meet online. Once you join you'll be able to post messages, upload pictures of your Tegu and enclosure and have a great time with other Tegu fans. Sign up today! If you have any questions, problems, or other concerns email josh@tegutalk.com!
    Dismiss Notice

Reptifogger broke in less the half a year.

Discussion in 'Reptile Product Reviews' started by TeguBlake, Feb 11, 2013.

  1. TeguBlake

    TeguBlake Member

    Joined:
    Sep 18, 2012
    Messages:
    547
    Likes Received:
    1
    Trophy Points:
    16
    So I took the old parks and made this nice fogger, that on its lowest setting is higher then the reptifogger lol :D

    Attached Files:

  2. TeguBuzz

    TeguBuzz Moderator 1,000+ Post Club

    Joined:
    Oct 10, 2011
    Messages:
    1,478
    Likes Received:
    75
    Trophy Points:
    48
    Same sort of fogger I used, except I used a larger humidifier I bought from Walgreens.
  3. BatGirl1

    BatGirl1 Active Member 1,000+ Post Club

    Joined:
    Sep 7, 2012
    Messages:
    1,198
    Likes Received:
    20
    Trophy Points:
    38
    My reptifogger is like a month or so old and already I have to mess with it to make it stop 'buzzing ' and actually blow the fog through the damn tube. Hoping it won't die or that I can at least fix it if it does...

    Sent from my ZTE-Z990G using Tapatalk 2
  4. TeguBlake

    TeguBlake Member

    Joined:
    Sep 18, 2012
    Messages:
    547
    Likes Received:
    1
    Trophy Points:
    16
    its the internal fan that broke on mine, it pushes the fogg throu your tube. seems to happen to alot of people. mine is from wallgreens to! lol this one is more then enough. on the lowest setting in my huge cage it was at 75 persent on the opisite side.:)
  5. BatGirl1

    BatGirl1 Active Member 1,000+ Post Club

    Joined:
    Sep 7, 2012
    Messages:
    1,198
    Likes Received:
    20
    Trophy Points:
    38
    I do believe it's the fan because when it buzzes no fog comes out even though it is building up fog inside. So I wonder if I can modify that fan somehow to correct the problem. . .

    Sent from my ZTE-Z990G using Tapatalk 2
    [hr]
    I feel like particles get sucked into the fan maybe from the base vents and make it so it can't spin properly...so perhsps if I can clear it from debris and oil it it will run more smoothly.

    Sent from my ZTE-Z990G using Tapatalk 2
    [hr]
    Perhaps*

    Sent from my ZTE-Z990G using Tapatalk 2
  6. TeguBlake

    TeguBlake Member

    Joined:
    Sep 18, 2012
    Messages:
    547
    Likes Received:
    1
    Trophy Points:
    16
    Mine burned out because of the sticky stuff holding it in fell into the fan... causeing it to buzz and scream... then it just quit out of no where.
  7. BatGirl1

    BatGirl1 Active Member 1,000+ Post Club

    Joined:
    Sep 7, 2012
    Messages:
    1,198
    Likes Received:
    20
    Trophy Points:
    38
    I think I will look inside and inspect the parts, clean them up, and perhaps elevate the unit to prevent so much 'floor debris ' from getting into the vents. If this stops the problem maybe others will benefit from my findings :) let's hope

    Sent from my ZTE-Z990G using Tapatalk 2
  8. dragonkeeperblue

    dragonkeeperblue Member

    Joined:
    Jan 19, 2013
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    Just a question does reptipro make that fogger?
  9. TeguBlake

    TeguBlake Member

    Joined:
    Sep 18, 2012
    Messages:
    547
    Likes Received:
    1
    Trophy Points:
    16
    Ahhh i dont know..? i could look into it though.
    [hr]
    Ahhh i dont know..? i could look into it though.
  10. Dubya

    Dubya Active Member 1,000+ Post Club

    Joined:
    Jun 30, 2012
    Messages:
    1,006
    Likes Received:
    25
    Trophy Points:
    38
    Zoo Med makes it. Mine is starting to make its death gurgles after about 6 mos.
  11. TeguBlake

    TeguBlake Member

    Joined:
    Sep 18, 2012
    Messages:
    547
    Likes Received:
    1
    Trophy Points:
    16
    They need to make these special reptile stuff more relyable
  12. Dubya

    Dubya Active Member 1,000+ Post Club

    Joined:
    Jun 30, 2012
    Messages:
    1,006
    Likes Received:
    25
    Trophy Points:
    38
    I will post a pic asap of Gwangis fogger output that is well over the bedding. He buries everything.
  13. Skeetzy

    Skeetzy Member

    Joined:
    Mar 19, 2012
    Messages:
    380
    Likes Received:
    15
    Trophy Points:
    18
    I have the same humidifier. You can actually get some PVC pieces that fit perfectly in the hole to route into the cage.

    Also, use a Smart Water 1L bottle. Way above recommended size, but mines but running 6 months and not a single leak from it.
  14. ToCoolTegu

    ToCoolTegu New Member

    Joined:
    Feb 20, 2013
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    0
    Hey! is there anyway you can give me the exact name of that fogger and a price on it? I have a repti fogger but i want to keep it on my crestie so I'd like to try that one:D
  15. HeatherN

    HeatherN Member

    Joined:
    Mar 22, 2012
    Messages:
    429
    Likes Received:
    8
    Trophy Points:
    18
    ive gone through two reptifoggers. just that damn fan i think. can you guys with the walgreens humidifiers put up the specs or something? :D
  16. BatGirl1

    BatGirl1 Active Member 1,000+ Post Club

    Joined:
    Sep 7, 2012
    Messages:
    1,198
    Likes Received:
    20
    Trophy Points:
    38
    I opened mine up and didn't even find anything 'wrong ' or clogged... ugh. There's more than one fan...
    I could only get to the one that apparently *wasn't * buzzing. Grrrr.
    Sent from my ZTE-Z990G using Tapatalk 2
  17. BatGirl1

    BatGirl1 Active Member 1,000+ Post Club

    Joined:
    Sep 7, 2012
    Messages:
    1,198
    Likes Received:
    20
    Trophy Points:
    38
    Ok I don't know if this has any bearing on anything but the performance of my reptifogger seems to have 'improved ' since I set it up into niles' big enclosure. Before I had it on the floor then tube going up and then arched down through the screen top of his breeder tank. Now he is in the 6x3x3...so I have the unit placed on top of the enclosure, with the tube extended full length, and through a hole in the back wall of the enclosure. I'll post a pic below. But it only buzzed a bit then it was fine. Now today there was no buzzing at all. (?) Strange. And last night I left it on all night so it ran out of water and shut off. This morning I turned the knob to off, refilled and turned back on. No problems at all! Twilight zone or...?haha ;p
    [hr]
    This is hose through hole inside ( under zero's butt) [attachment=6613] and this is the unit on top of the enclosure [attachment=6614]

    Attached Files:

Share This Page